A Singapore Government Agency Website 

avatar1 in

What are the minimum android and ios versions required to use the MyPAssion mobile app?

paLogo

pa

For Android phone users, Android 7.1 onwards and for iPhone users, iOS 13 onwards.


Let other citizens know if this answer was helpful
Did this answer your question?

Can’t find what you’re looking for?